Norconex JEF API

Download

Releases

4.1.3-SNAPSHOT Download View release notes 2020-01-27 Bugfix release
4.1.2 Download View release notes 2019-12-22 Maintenance release
Older releases
4.1.1 Download View release notes 2018-06-28 Bugfix release
4.1.0 Download View release notes 2017-04-25 Minor release
4.0.8 Download View release notes 2016-12-13 Bug fix release
4.0.7 Download View release notes 2015-11-02 Bug fix release
4.0.6 Download View release notes 2015-07-21 Maintenance release
4.0.5 Download View release notes 2015-04-10 Bug fix release
4.0.4 Download View release notes 2015-04-08 Bug fix release
4.0.3 Download View release notes 2015-04-02 Maintenance release
4.0.2 Download View release notes 2015-02-04 Bug fix release
4.0.1 Download View release notes 2014-12-03 Maintenance release
4.0.0 Download View release notes 2014-11-25 Major release

Source

Source code can be obtained on GitHub: https://github.com/Norconex/jef.

Maven

Maven users can add the following to their pom.xml:

<dependency>
  <groupId>com.norconex.collectors</groupId>
  <artifactId>norconex-jef</artifactId>
  <version>4.1.2</version>
</dependency>

Use the following for the latest snapshot release:

<dependency>
  <groupId>com.norconex.collectors</groupId>
  <artifactId>norconex-jef</artifactId>
  <version>4.1.3-SNAPSHOT</version>
</dependency>

For snapshot releases, make sure to include the public Sonatype Maven repository:

<repository>
  <id>sonatype.oss.snapshots</id>
  <name>Sonatype OSS Snapshot Repository</name>
  <url>http://oss.sonatype.org/content/repositories/snapshots</url>
  <releases>
    <enabled>false</enabled>
  </releases>
  <snapshots>
    <enabled>true</enabled>
  </snapshots>
</repository> 

Version 5.0.0 is coming!

The latest binary snapshot for upcoming 5.0.0 version is now available for download. Be warned this new version is still under development and may experience breaking changes from one snapshot to the next, until official release. Unless you are a contributor or the adventurous type, we recommend you stick to version 4.x.